Win BIG in the Connect IT Community Favorite Things Giveaway! Get started here > https://www.community.connectit.com/discussion/39016/win-big-in-the-connect-it-community-favorite-things-giveaway

Windows 10 Feature Update

13»

Comments

  • Kenneth L. Nagel
    edited June 2

    sorry that was my bad.. got click happy.. LOL

  • Alan Sudweeks
    Alan Sudweeks Member
    edited June 2

    Thank for that update.  That gives me a great place to start.  We are running just over 300 pcs with 3 of us.  so we keep super busy.  :)  Kaseya has been a life saver

  • Habakkuk Caleb
    edited June 2

    I am unable to import the .xml file to VSA, is there any issues?


  • Alan Sudweeks
    Alan Sudweeks Member
    edited June 2

    Habakkuk,  You may need to change your settings to allow that file type to upload to the VSA

  • Habakkuk Caleb
    edited June 3

    Alan, I am able to upload other .xml files except this one.

  • Todd Reibling
    Todd Reibling Member CHOCOLATE MILK
    edited June 3

    I found that I could not upload this xml into the agent procedure interface, but I could upload/import it via the System module > Import Center.  It then shows the additional parts that are imported as well. i.e. views, report, and the agent procedure all at once.

  • SHRI MUTHULINGAM
    SHRI MUTHULINGAM Member CHOCOLATE MILK
    edited June 10

    Hi

    My reporting is not working as described in the instruction. It is not grouping as 2004 or 2009. It is listing version#14.x.x.x.x..


  • Wissam Oreibi
    Wissam Oreibi Member CHOCOLATE MILK
    edited June 17

    Hi,

    I was able to download files and import them.
    I tried to test it on a test Virtual machine with windows 10 build 1803. The
    procedure appears to download windows update assistant and install it then
    download the installation files over the internet and finally reboot virtual
    machine in about 1 to 2 hrs of time. Unfortunately, after reboot, the build is
    not upgraded and there is no logs in log folder neither in event viewer with no
    entries showing if there was an issue.

    Running the same command that procedure is
    executing manually via a logged on user does upgrade the OS build
    successfully. 

    The Virtual machine we are testing with is in
    trial as it is a fresh install. We have tried procedure on a physical laptop
    with an active windows 10 build 1909 and we had same result as explained above.
    So it appears that when procedure is running in background it does some of
    steps but after reboot build is not upgraded while if we execute same command used
    by procedure manually the upgrade works.

    Anyone may have encountered the same issue
    that might be able to shed some light on this and point us into right
    direction.

    Command that procedure uses in background is:

    Windows10Upgrade9252.exe /quietinstall
    /skipeula /auto upgrade /copylogs <pathtologdirectory>















    Thanks,

  • Tommie Gowdy
    Tommie Gowdy Member
    edited June 17


    @Wissam Oreibi

    I am no expert but just how it was explained I wonder if you add login credentials or no reboot to script maybe this would work?

    10

  • Wissam Oreibi
    Wissam Oreibi Member CHOCOLATE MILK
    edited June 17

    I know that Dev who wrote the script executed command as "system" which has admin privileges'. I am not familiar with how to add login credentials to procedure. I would imagine I will need to edit procedure that was written and amended it. Do you happen to know how this can be done, if you can past a line.

    for example in Developer procedure he has this line which basically saves command into a powershell then execute as system. What makes me wonder is others in this discussion thread said it worked for them but did not hear that procedure needed modification !!

    executeshellcommand("echo #vAgentConfiguration.agentTempDir#\Windows10Upgrade9252.exe /quietinstall /skipeula /auto upgrade /copylogs #vAgentConfiguration.agentTempDir#\logs >> #vAgentConfiguration.agentTempDir#\WindowsUpgrade.ps1","Execute as System", "All Operating Systems", "Halt on Fail")


  • Timothy Smith
    Timothy Smith Member
    edited June 18

    Wissam,

    If you would like the command to simply execute as the logged on user, change "Execute as System" to "Execute as User". If a user is logged it, it will run as that specific user.

    To use the credentials applied to the machine, however, change to "Execute as User" AND add useCredential above executeShellCommand. After that, this is what it should look like:

    useCredential("All Operating Systems", "Halt on Fail")
    executeshellcommand("echo #vAgentConfiguration.agentTempDir#\Windows10Upgrade9252.exe /quietinstall /skipeula /auto upgrade /copylogs #vAgentConfiguration.agentTempDir#\logs >> #vAgentConfiguration.agentTempDir#\WindowsUpgrade.ps1","Execute as User", "All Operating Systems", "Halt on Fail")

    Now, as for the script working for others but not yourself, that would really depend on your environment compared to what makes theirs work. I would suggest that you run the script twice on a machine to test, before making the above modifications. If you ran it once and it failed, but then ran the upgrade another way and it worked, it could mean that another execution got it to work in general, not that a manual execution was the only working solution.

    So please try running it twice in a row on another machine without modifications and report back.

  • Ken
    Ken Member
    edited June 18

    Just be mindful of the User Account Control (UAC) popup that "might" happen, prompting for the "OK" to continue. Script will fail.

    It can be a real pain to find unless you are looking for it.

  • Luc Celestin
    Luc Celestin Member
    edited June 18

    I have tried this version 2 and this is still not executing. When the script start it pushes the windows update assistant and then executes that file. However, the update assistant doesn't seem to work.

    Fri, 18 Jun 2021 05:11:00 GMT  [ KSM ] ------------------------------------------------------   SM JS Patch Version 9.5.5.30  ------------------------------------------------------
    Fri, 18 Jun 2021 05:11:00 GMT [ KSM ] ScriptMain "{\"RequestId\":\"71a83eee-a13b-415d-868f-86cccb0f7839\",\"PartitionId\":\"1\",\"OperationCategory\":\"GetWindowsAutoUpdateValues\",\"SelectedAgent\":\"336025519941636\",\"Success\":true,\"Error\":\"\",\"ResponseDate\":\"0001-01-01T00:00:00\",\"EndpointId\":\"\",\"IsForceUpdate\":false,\"FileNameGuid\":\"\",\"Conduit\":\"SM\",\"Plugin\":\"Kaseya.SM.Common\",\"Class\":\"OperationMessagesIncoming\",\"StartDateTime\":\"2021-05-30T15:23:57.2003886-04:00\",\"IsWindowsUpdateInfoProvided\":false,\"IsWindows10\":null,\"NoAutoUpdate\":null,\"AUOptions\":null,\"ScheduledInstallDay\":null,\"ScheduledInstallTime\":null,\"NoAutoRebootWithLoggedOnUsers\":null,\"UxOption\":null}"
    Fri, 18 Jun 2021 05:11:00 GMT [ KSM ] utilApi.processRequest vsaRequest.OperationCategory: GetWindowsAutoUpdateValues
    Fri, 18 Jun 2021 05:11:00 GMT [ KSM ] Get Windows Auto Update Values
    Fri, 18 Jun 2021 05:11:00 GMT [ KSM ] WAU settings have not changed.
    Fri, 18 Jun 2021 11:11:00 GMT [ KSM ] ------------------------------------------------------ SM JS Patch Version 9.5.5.30 ------------------------------------------------------
    Fri, 18 Jun 2021 11:11:00 GMT [ KSM ] ScriptMain "{\"RequestId\":\"71a83eee-a13b-415d-868f-86cccb0f7839\",\"PartitionId\":\"1\",\"OperationCategory\":\"GetWindowsAutoUpdateValues\",\"SelectedAgent\":\"336025519941636\",\"Success\":true,\"Error\":\"\",\"ResponseDate\":\"0001-01-01T00:00:00\",\"EndpointId\":\"\",\"IsForceUpdate\":false,\"FileNameGuid\":\"\",\"Conduit\":\"SM\",\"Plugin\":\"Kaseya.SM.Common\",\"Class\":\"OperationMessagesIncoming\",\"StartDateTime\":\"2021-05-30T15:23:57.2003886-04:00\",\"IsWindowsUpdateInfoProvided\":false,\"IsWindows10\":null,\"NoAutoUpdate\":null,\"AUOptions\":null,\"ScheduledInstallDay\":null,\"ScheduledInstallTime\":null,\"NoAutoRebootWithLoggedOnUsers\":null,\"UxOption\":null}"
    Fri, 18 Jun 2021 11:11:00 GMT [ KSM ] utilApi.processRequest vsaRequest.OperationCategory: GetWindowsAutoUpdateValues
    Fri, 18 Jun 2021 11:11:00 GMT [ KSM ] Get Windows Auto Update Values
    Fri, 18 Jun 2021 11:11:00 GMT [ KSM ] WAU settings have not changed.
  • Luc Celestin
    Luc Celestin Member
    edited June 18

    if the Feature update xml is running how can we verify if the update is actually running? Are there logs from the VSA that we can check? or through Live connect processes? I have checked the Software management logs or Agent logs, but for me I am monitoring the traffic through my palo alto firewall and i can only see the PC talking to Microsoft, but physically on the machine or through Kaseya we should have a progression window or status window.

  • Luc Celestin
    Luc Celestin Member
    edited June 18

    the windows feature update creates an windows 10 upgrade folder in the C:\kworking folder or in the C:\ however when I execute this windows 10 update assistant i receive the following error code 0a0000400. 


    Extend codes

     Important

    Extend codes reflect the current Windows 10 upgrade process, and might change in future releases of Windows 10. The codes discussed in this section apply to Windows 10 version 1607, also known as the Anniversary Update.

    Extend codes can be matched to the phase and operation when an error occurred. To match an extend code to the phase and operation:

    1. Use the first digit to identify the phase (ex: 0x4000D = 4).
    2. Use the last two digits to identify the operation (ex: 0x4000D = 0D).
    3. Match the phase and operation to values in the tables provided below.

    The following tables provide the corresponding phase and operation for values of an extend code:

    https://docs.microsoft.com/en-us/windows/deployment/upgrade/upgrade-error-codes#result-codes


    TABLE 2
    Extend code: phase
    HexPhase
    0SP_EXECUTION_UNKNOWN
    1SP_EXECUTION_DOWNLEVEL
    2SP_EXECUTION_SAFE_OS
    3SP_EXECUTION_FIRST_BOOT
    4SP_EXECUTION_OOBE_BOOT
    5SP_EXECUTION_UNINSTALL
  • Wissam Oreibi
    Wissam Oreibi Member CHOCOLATE MILK
    edited June 18

    Hi,

    Thanks Guys for the feedback. Today I tested using:

     useCredential("All Operating Systems", "Halt on Fail") line in procedure. Details below on modification I made to procedure so it started working with no issues on a test Virtual machine and also on a physical laptop. Hope this help someone else who might get stuck on this procedure when they try it in Kaseya.

    First:

    - you will need to set credentials for agent in kaseya agent menu:

    go to "manage agents" under agent menu then select checkbox next a computer and click on drop down menu above "Credentials" and click on set credentials. you can set local admin user or domain admin user. As long as local or domain admin user does exist and is a member of administrator local group , then click ok.

    after that again select drop down menu "credentials and choose "test credentials" then click ok

    Head to agent logs submenu now and check "key" icon which should test credentials in a minute or so and then it should give "key" icon colored in black if it passed credential test.

    once this is done then come editing procedure. Areas where I editted.

    1. Delete line 19 which is "scheduleProcedure("","360","All Operating Systems", "halt on Fail")

    2. add 2 new lines under line 20 as follows:

    useCredential("All Operating Systems", "Halt on Fail")

    executePowershellCommand64BitUser(" ","#vAgentConfiguration.agentTempDir#\WindowsUpgrade.ps1",false,"All Operating Systems", "Halt on Fail")

    3. delete original line 21 below:

    executePowershellCommand64BitSystem(" ","#vAgentConfiguration.agentTempDir#\WindowsUpgrade.ps1",false,"All Operating Systems", "Halt on Fail")

    4. add two lines under line 22:

    useCredential("All Operating Systems", "Halt on Fail")

    executePowershellCommand32BitUser(" ","#vAgentConfiguration.agentTempDir#\WindowsUpgrade.ps1",false,"All Operating Systems", "Halt on Fail")

    5. delete original line 23 below:

    executePowershellCommand32BitSystem(" ","#vAgentConfiguration.agentTempDir#\WindowsUpgrade.ps1",false,"All Operating Systems", "Halt on Fail")

    Please note that order of lines may change as you start to add new lines so take note or all line numbers ahead of adding any new lines so you know which one to delete.

    As mentioned before, this has worked from first try on a Virtual machine and on a physical laptop and upgrade completed with a few reboots with no user interaction until it was ready to be logged on.


    Cheers,

  • Nathan Harris
    Nathan Harris Member CHOCOLATE MILK

    Hey guys, as of recently, when I try to import the XML, I get the following error:

    • File was not uploaded due to incorrectly formatted XML.Please export the content to a new XML file and try again.

    Please let me know if this can be corrected.

    Thanks!

Weekly Leaderboard