Happy Independence Day from all of us at the Connect IT Community! Our US offices will be closed on Monday, July 4th, 2022 in recognition of the holiday. Limited Support staff in the US will be on-call and available for critical Service(s) Down issues only. Normal Support operations in the US will resume on Tuesday, July 5th, 2022.

Set Adobe Reader to Default

Kaseya Automation Team
Kaseya Automation Team USMember, Kaseya Certified CHOCOLATE MILK
edited January 24 in Solutions

Product Name: Set Adobe Reader to Default

Description : this agent procedure uses the provided SFTA.exe to set adobe reader as the default reader.

Instructions :

unzip the attached zip file.

upload the SFTA.exe to the Shared Files

import the attached xml in the Agent Procedure Module

Edit the procedure and confirm all variables/files are pointing to the right directions.

Comments

  • Rishi Tripathi
    Rishi Tripathi IndiaMember CHOCOLATE MILK

    Hey,


    I have tried the suggested steps but still, Edge is showing the default browser. The procedure was executed successfully without any error.

    Awaiting for your response

  • Macro47
    Macro47 Member CHOCOLATE MILK

    In lines 8, and 14, try changing AcroExch to Acrobat

    They should read:

    8) executePowershell (" ", "Get-ItemProperty HKLM:\SOFTWARE\Classes\.pdf\OpenWithProgids\|Select-Object -ExpandProperty Acrobat.Document.DC -ErrorAction Stop ; Write-host "True", true, "....")

    14) executeFile ("#ktemp#\SFTA\SFTA.exe", "Acrobat.Document.DC .pdf", "....")


    This should also work with Acrobat Standard DC without editing. If it sets a reader as the default, uninstall the "Reader" version of acrobat.

  • Trevor Okazaki
    Trevor Okazaki Member CHOCOLATE MILK

    @Rishi Tripathi I just ran it and it works but only if a user is logged in at the time. So unfortunately I can't set it to automatically run when the VSA agent is installed but it's there to fix the issue. Not sure if it's faster than just changing it manually or not. Probably faster than if you have to open Live Connect to remote in to a computer and then go change the Default App settings.