PROBLEM
My agents are on machines that have to go via a proxy server to reach the internet.
The agents are not able to check in to the Kaseya server (they remain grey)
CAUSE
The Kaseya Agents require a direct TCP/IP connection to the Kaseya Server - they are not proxy aware.
WORKAROUND / SOLUTION
In order for a Kaseya Agent to successfully check-in to the Kaseya server, you must allow outbound connections from the agent machine to the kaseya server directly.
There is no way to tell the agent to use a proxy server.
ADDITIONAL INFORMATION
How to diagnose "grey" agents - https://kaseya.zendesk.com/entries/27862397-How-to-diagnose-grey-agents
Troubleshooting Kaseya Agent check-in problems - https://kaseya.zendesk.com/entries/32389373-Troubleshooting-Kaseya-Agent-check-in-problems