SUMMARY
How do I fix a FirstBootFailure error when attempting to deploy my VM?
ISSUE
This is always a tricky problem to work out.
Please take a look at this page: http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/VMImportTroubleshooting.html
RESOLUTION
To fix this, boot the VM on vSphere at least once before replicating it again.You will see a section for FirstBootFailure. There are a number of configuration items to look over.
If your configuration looks correct, you try restarting the import process. Occasionally we have encountered API failures on this, and we have found that restarting the import works.
CAUSE
There are several known causes of this error.
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When you CopyBack a Windows VM from AWS or Azure to vSphere, replicate it and deploy it again on AWS without booting it vSphere you may encounter this error. It is caused by Windows not being properly notified about the relocation. To fix this, boot the VM on vSphere at least once before replicating it again. You will see a section for FirstBootFailure. There are a number of configuration items to look over. If your configuration looks correct, you try restarting the import process
- If the original VM disk configuration contains GPT formatted disks, then this error will occur. Currently, AWS does NOT support VMs with GPT formatted disks.
- If the vSphere VM that has been replicated into AWS using Boomerang was originally created on vSphere using a P2V process then this error can occur. AWS only supports importing VMs that were installed using the original OS install media/iso images.